Rule with staffMail call does not appear to be firing since March 26th

Jesse
Jesse Member

Hello!

We have a Rule where we use the staffMail function to send over a limited set of data from the student's application in order for us to immediately take action in our CRM, but ever since March 26th, we no longer receive any emails sent via the staffMail function as configured.

Previously I thought the issue was on our side due to how we were parsing the email, but our third-party email parser tool is working fine (we can send manually).

I believe there is some issue with CCCApply sending the email via the staffMail() function in a rule to our mail parser. The rule is called "email-to-mailparser-io."

This is the Rule configuration that was testing and working fine until March 26th:

if (1 == 1)
{
  staffMail("[email protected]", "email-to-mailparser-io", "[email protected]", "New student data")
}

We have tried different email addresses for the "from" field to no avail.

I recently re-applied to Calbright (CCCID: BQK8861) and confirmed that this is still broken.

As I was writing this, I modified the above rule as follows:

if (1 == 1)
{
  staffMail("[email protected]", "email-to-mailparser-io", "[email protected]", "New student data")

  staffMail("[email protected]", "debug-staffmail-message", "[email protected]", "staffMail confirmation")
}

Neither of these staffMail() blocks are firing. (I would have expected at least the second (new) one to fire).

Is there any way you can see whether the Rule is firing and/or whether staffMail() is no longer working as intended?

Additionally, are there restrictions on what email address we can send to via the staffMail() function in Rules? If so, what are they (and did they change on March 26th when this suddenly stopped working?)

The only thing I can think of here is that either a) staffMail() no longer allows emails to domains outside of the school's primary TLD, b) something else was updated on or around March 26th that caused this to no longer work.

Please let me know if there's anything else I can provide to help troubleshoot. Again, this was tested and working fine until March 26th--and hasn't worked for any student application since then.

Thank you,

Jesse Lawson, Director of Information Systems @ Calbright College