-keypasswd commands not supported

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
I am trying to install the CCCApply Download Client (test environment) and I am getting a Java error.

I am following the steps in the user guide (Download Client User Guide V.2017.1 dated 3/31/17) & I'm @ step #3f under "Download Client Installations Steps". When I enter the command to update my college key password to match the keystore password I just updated in step #3e I get the following error:

keytool error: java.lang.UnsupportedOperationException: -keypasswd commands not supported if -storetype is PKCS12

What do I need to do to update my college key password to match the keystore password I just updated in step #3e?
Photo of Mark Hopkins

Mark Hopkins

  • 6 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Merrie Wales

Merrie Wales, Official Rep

  • 960 Posts
  • 57 Reply Likes
Mark,
So you used your original download client, upgraded it from the download site: https://cccnext.jira.com/wiki/spaces/PD/pages/131465643/Download+Client
and during that process you changed your password, and are now receiving the keytool error?
Photo of Mark Hopkins

Mark Hopkins

  • 6 Posts
  • 1 Reply Like

Merrie,

Yes, I'm  trying to install the original download client following the directions I've cited. I changed the password per step #3e, and when I try to execute the command listed in step #3f I get the error.

Photo of Merrie Wales

Merrie Wales, Official Rep

  • 960 Posts
  • 57 Reply Likes
Mark,
I am glad that using Java 8 and making sure the structure of your test string contained the data needed to get a complete connection worked.